What’s Vulnerable › Vulnerabilities
CVE-2022-37866: Apache Ivy allows path traversal in the presence of a malicious repository
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-07 · updated 2026-06-17
- Weakness: CWE-22
Description
When Apache Ivy downloads artifacts from a repository it stores them in the local file system based on a user-supplied "pattern" that may include placeholders for artifacts coordinates like the organisation, module or version. If said coordinates contain "../" sequences - which are valid characters for Ivy coordinates in general - it is possible the artifacts are stored outside of Ivy's local cache or repository or can overwrite different artifacts inside of the local cache. In order to exploit this vulnerability an attacker needs collaboration by the remote repository as Ivy will issue http requests containing ".." sequences and a "normal" repository will not interpret them as part of the artifact coordinates. Users of Apache Ivy 2.0.0 to 2.5.1 should upgrade to Ivy 2.5.1.
Affected products
- Apache Software Foundation Apache Ivy: from 2.0.0 before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ivy 2.5.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/htxbr8oc464hxrgroftnz3my70whk93b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YDIFDL5WSBEKBUVKTABUFDDD25SBNJLS/
- https://lists.apache.org/thread/htxbr8oc464hxrgroftnz3my70whk93b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YDIFDL5WSBEKBUVKTABUFDDD25SBNJLS/
Get alerted when CVE-2022-37866 or the next vulnerability affects your stack