What’s Vulnerable › Vulnerabilities
CVE-2022-37892
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-07 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the Aruba InstantOS and ArubaOS 10 web management interface could allow an unauthenticated remote attacker to conduct a stored cross-site scripting (XSS) attack against a user of the interface. A successful exploit could allow an attacker to execute arbitrary script code in a victim’s browser in the context of the affected interface of Aruba InstantOS 6.4.x: 6.4.4.8-4.2.4.20 and below; Aruba InstantOS 6.5.x: 6.5.4.23 and below; Aruba InstantOS 8.6.x: 8.6.0.18 and below; Aruba InstantOS 8.7.x: 8.7.1.9 and below; Aruba InstantOS 8.10.x: 8.10.0.1 and below; ArubaOS 10.3.x: 10.3.1.0 and below; Aruba has released upgrades for Aruba InnstantOS that address this security vulnerability.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.3.0.0 before 10.3.1.1 — fixed in 10.3.1.1
- Arubanetworks Instant: from 6.4.0.0 before 6.4.4.8-4.2.4.21; from 6.5.0.0 before 6.5.4.24; from 8.6.0.0 before 8.6.0.19; from 8.7.0.0 before 8.7.1.10; from 8.10.0.0 before 8.10.0.2 — fixed in 6.4.4.8-4.2.4.21, 6.5.4.24, 8.10.0.2, 8.6.0.19, 8.7.1.10
- Siemens Scalance W1750D Firmware: all versions
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.3.1.1; Arubanetworks Instant 6.4.4.8-4.2.4.21, 6.5.4.24, 8.10.0.2, 8.6.0.19. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-506569.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-014.txt
- https://cert-portal.siemens.com/productcert/pdf/ssa-506569.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-014.txt
Get alerted when CVE-2022-37892 or the next vulnerability affects your stack