What’s Vulnerable › Vulnerabilities
CVE-2022-37900
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-12 · updated 2026-10-09
- Weakness: CWE-78
Description
Authenticated command injection vulnerabilities exist in the ArubaOS command line interface. Successful exploitation of these vulnerabilities results in the ability to execute arbitrary commands as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 6.5.4.0 before 6.5.4.23; from 8.4.0.0 before 8.6.0.18; from 8.7.0.0 before 8.7.1.10; from 8.8.0.0 before 8.10.0.0; 10.3.0.0 — fixed in 6.5.4.23, 8.10.0.0, 8.6.0.18, 8.7.1.10
- Arubanetworks Sd-Wan: from 8.5.0.0-2.1.0.0 before 8.7.0.0-2.3.0.7 — fixed in 8.7.0.0-2.3.0.7
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 6.5.4.23, 8.10.0.0, 8.6.0.18, 8.7.1.10; Arubanetworks Sd-Wan 8.7.0.0-2.3.0.7. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-016.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-016.txt
Get alerted when CVE-2022-37900 or the next vulnerability affects your stack