What’s Vulnerable › Vulnerabilities
CVE-2022-37904
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-12 · updated 2026-10-09
- Weakness: CWE-123
Description
Vulnerabilities in ArubaOS running on 7xxx series controllers exist that allows an attacker to execute arbitrary code during the boot sequence. Successful exploitation could allow an attacker to achieve permanent modification of the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 6.5.4.0 before 6.5.4.23; from 8.4.0.0 before 8.6.0.18; from 8.7.0.0 before 8.7.1.10; from 8.8.0.0 before 8.10.0.0; 10.3.0.0 — fixed in 6.5.4.23, 8.10.0.0, 8.6.0.18, 8.7.1.10
- Arubanetworks Sd-Wan: from 8.5.0.0-2.1.0.0 before 8.7.0.0-2.3.0.7 — fixed in 8.7.0.0-2.3.0.7
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 6.5.4.23, 8.10.0.0, 8.6.0.18, 8.7.1.10; Arubanetworks Sd-Wan 8.7.0.0-2.3.0.7. Check the vendor advisory for mitigations.
References
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-016.txt
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2022-016.txt
Get alerted when CVE-2022-37904 or the next vulnerability affects your stack