What’s Vulnerable › Vulnerabilities
CVE-2022-37928
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-12 · updated 2026-06-17
- Weakness: CWE-345
Description
Insufficient Verification of Data Authenticity vulnerability in Hewlett Packard Enterprise HPE Nimble Storage Hybrid Flash Arrays and Nimble Storage Secondary Flash Arrays.
Affected products
- HPE Hf20 Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Hf20C Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Hf20H Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Hf40 Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Hf40C Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Hf60 Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Hf60C Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Sf100 Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
- HPE Sf300 Firmware: before 5.2.1.900; 5.3.0.0 — fixed in 5.2.1.900
How to fix
Upgrade to a fixed version: HPE Hf20 Firmware 5.2.1.900; HPE Hf20C Firmware 5.2.1.900; HPE Hf20H Firmware 5.2.1.900; HPE Hf40 Firmware 5.2.1.900; HPE Hf40C Firmware 5.2.1.900; HPE Hf60 Firmware 5.2.1.900; HPE Hf60C Firmware 5.2.1.900; HPE Sf100 Firmware 5.2.1.900; HPE Sf300 Firmware 5.2.1.900. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst04359en_us
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst04359en_us
Get alerted when CVE-2022-37928 or the next vulnerability affects your stack