What’s Vulnerable › Vulnerabilities

CVE-2022-3793

Description

An improper authorization issue in GitLab CE/EE affecting all versions from 14.4 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows an attacker to read variables set directly in a GitLab CI/CD configuration file they don't have access to.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.3.5, 15.4.4, 15.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3793 or the next vulnerability affects your stack