What’s Vulnerable › Vulnerabilities
CVE-2022-3794: Jeg Elementor Kit <= 2.5.6 - Authorization Bypass
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-639
Description
The Jeg Elementor Kit plugin for WordPress is vulnerable to authorization bypass in various AJAX actions in versions up to, and including, 2.5.6. Authenticated users can use an easily available nonce value to create header templates and make additional changes to the site, as the plugin does not use capability checks for this purpose.
Affected products
- jegtheme Jeg Kit for Elementor – Powerful Addons for Elementor, Widgets & Templates for WordPress: before 2.5.7 — fixed in 2.5.7
How to fix
Upgrade to a fixed version: jegtheme Jeg Kit for Elementor – Powerful Addons for Elementor, Widgets & Templates for WordPress 2.5.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2811758%40jeg-elementor-kit%2Ftrunk&old=2810568%40jeg-elementor-kit%2Ftrunk&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/jeg-elementor-kit/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/84b616fa-ff64-49e8-8c4a-7d7bfdf758be?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2811758%40jeg-elementor-kit%2Ftrunk&old=2810568%40jeg-elementor-kit%2Ftrunk&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/jeg-elementor-kit/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/84b616fa-ff64-49e8-8c4a-7d7bfdf758be
Get alerted when CVE-2022-3794 or the next vulnerability affects your stack