What’s Vulnerable › Vulnerabilities
CVE-2022-37968: Azure Arc-enabled Kubernetes cluster Connect Elevation of Privilege Vulnerability
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-11 · updated 2026-06-17
Description
Microsoft has identified a vulnerability affecting the cluster connect feature of Azure Arc-enabled Kubernetes clusters. This vulnerability could allow an unauthenticated user to elevate their privileges and potentially gain administrative control over the Kubernetes cluster. Additionally, because Azure Stack Edge allows customers to deploy Kubernetes workloads on their devices via Azure Arc, Azure Stack Edge devices are also vulnerable to this vulnerability.
Affected products
- Microsoft Azure Arc-Enabled Kubernetes: 1.5.8, 1.6.19, 1.7.18, 1.8.11
- Microsoft Azure Stack Edge: all versions
- Microsoft Azure Arc-enabled Kubernetes cluster 1.5.8: from 1.0.0 before 1.5.8 — fixed in 1.5.8
- Microsoft Azure Arc-enabled Kubernetes cluster 1.6.19: from 1.0.0 before 1.6.19 — fixed in 1.6.19
- Microsoft Azure Arc-enabled Kubernetes cluster 1.7.18: from 1.0.0 before 1.7.18 — fixed in 1.7.18
- Microsoft Azure Arc-enabled Kubernetes cluster 1.8.11: from 1.0.0 before 1.8.11 — fixed in 1.8.11
- Microsoft Azure Stack Edge: from 2.2.0 before 2.2.2088.5593 — fixed in 2.2.2088.5593
How to fix
Upgrade to a fixed version: Microsoft Azure Arc-enabled Kubernetes cluster 1.5.8 1.5.8; Microsoft Azure Arc-enabled Kubernetes cluster 1.6.19 1.6.19; Microsoft Azure Arc-enabled Kubernetes cluster 1.7.18 1.7.18; Microsoft Azure Arc-enabled Kubernetes cluster 1.8.11 1.8.11; Microsoft Azure Stack Edge 2.2.2088.5593. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-37968
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2022-37968
Get alerted when CVE-2022-37968 or the next vulnerability affects your stack