What’s Vulnerable › Vulnerabilities
CVE-2022-38170: Overly permissive umask for daemons
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-02 · updated 2026-06-17
- Weakness: CWE-732
Description
In Apache Airflow prior to 2.3.4, an insecure umask was configured for numerous Airflow components when running with the `--daemon` flag which could result in a race condition giving world-writable files in the Airflow home directory and allowing local users to expose arbitrary file contents via the webserver.
Affected products
- Apache Airflow: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: Apache Airflow 2.3.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/09/02/12
- http://www.openwall.com/lists/oss-security/2022/09/02/3
- http://www.openwall.com/lists/oss-security/2022/09/21/2
- https://lists.apache.org/thread/zn8mbbb1j2od5nc9zhrvb7rpsrg1vvzv
- http://www.openwall.com/lists/oss-security/2022/09/02/12
- http://www.openwall.com/lists/oss-security/2022/09/02/3
- http://www.openwall.com/lists/oss-security/2022/09/21/2
- https://lists.apache.org/thread/zn8mbbb1j2od5nc9zhrvb7rpsrg1vvzv
Get alerted when CVE-2022-38170 or the next vulnerability affects your stack