What’s Vulnerable › Vulnerabilities
CVE-2022-3818
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-10 · updated 2026-06-17
- Weakness: CWE-400
Description
An uncontrolled resource consumption issue when parsing URLs in GitLab CE/EE affecting all versions prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows an attacker to cause performance issues and potentially a denial of service on the GitLab instance.
Affected products
- GitLab: before 15.3.5; from 15.4.0 before 15.4.4; from 15.5.0 before 15.5.2 — fixed in 15.3.5, 15.4.4, 15.5.2
How to fix
Upgrade to a fixed version: GitLab 15.3.5, 15.4.4, 15.5.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3818.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/358170
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3818.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/358170
Get alerted when CVE-2022-3818 or the next vulnerability affects your stack