What’s Vulnerable › Vulnerabilities
CVE-2022-3820
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-290
Description
An issue has been discovered in GitLab affecting all versions starting from 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. GitLab was not performing correct authentication with some Package Registries when IP address restrictions were configured, allowing an attacker already in possession of a valid Deploy Token to misuse it from any location.
Affected products
- GitLab: from 15.4.0 before 15.4.6; from 15.5.0 before 15.5.5; 15.6.0 — fixed in 15.4.6, 15.5.5
How to fix
Upgrade to a fixed version: GitLab 15.4.6, 15.5.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3820.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/378638
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3820.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/378638
Get alerted when CVE-2022-3820 or the next vulnerability affects your stack