What’s Vulnerable › Vulnerabilities
CVE-2022-3822: Donations via PayPal < 1.9.9 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-28 · updated 2026-06-17
Description
The Donations via PayPal WordPress plugin before 1.9.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Donations via PayPal: before 1.9.9 — fixed in 1.9.9
How to fix
Upgrade to a fixed version: Donations via PayPal 1.9.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/48ec2e4a-0190-4f36-afd1-d5799ba28c13
- https://wpscan.com/vulnerability/48ec2e4a-0190-4f36-afd1-d5799ba28c13
Get alerted when CVE-2022-3822 or the next vulnerability affects your stack