What’s Vulnerable › Vulnerabilities
CVE-2022-3832: External Media < 1.0.36 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
Description
The External Media WordPress plugin before 1.0.36 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- External Media: before 1.0.36 — fixed in 1.0.36
How to fix
Upgrade to a fixed version: External Media 1.0.36. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/458ec2fd-4175-4cb4-b334-b63f6e643b92
- https://wpscan.com/vulnerability/458ec2fd-4175-4cb4-b334-b63f6e643b92
Get alerted when CVE-2022-3832 or the next vulnerability affects your stack