What’s Vulnerable › Vulnerabilities
CVE-2022-38362: Docker Provider <3.0 RCE vulnerability in example dag
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-16 · updated 2026-06-17
Description
Apache Airflow Docker's Provider prior to 3.0.0 shipped with an example DAG that was vulnerable to (authenticated) remote code exploit of code on the Airflow worker host.
Affected products
- Apache-Airflow-Providers-Docker: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Apache-Airflow-Providers-Docker 3.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/08/16/1
- https://lists.apache.org/thread/614p38nf4gbk8xhvnskj9b1sqo2dknkb
- http://www.openwall.com/lists/oss-security/2022/08/16/1
- https://lists.apache.org/thread/614p38nf4gbk8xhvnskj9b1sqo2dknkb
Get alerted when CVE-2022-38362 or the next vulnerability affects your stack