What’s Vulnerable › Vulnerabilities
CVE-2022-3845: phpipam Import Preview import-load-data.php cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-02 · updated 2026-06-17
- Weakness: CWE-707
Description
A vulnerability has been found in phpipam and classified as problematic. Affected by this vulnerability is an unknown functionality of the file app/admin/import-export/import-load-data.php of the component Import Preview Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 22c797c3583001211fe7d31bccd3f1d4aeeb3bbc. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-212863.
Affected products
- phpipam/phpipam: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: phpipam/phpipam 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/phpipam/phpipam/commit/22c797c3583001211fe7d31bccd3f1d4aeeb3bbc
- https://github.com/phpipam/phpipam/releases/tag/v1.5.0
- https://vuldb.com/?id.212863
- https://github.com/phpipam/phpipam/commit/22c797c3583001211fe7d31bccd3f1d4aeeb3bbc
- https://github.com/phpipam/phpipam/releases/tag/v1.5.0
- https://vuldb.com/?id.212863
Get alerted when CVE-2022-3845 or the next vulnerability affects your stack