What’s Vulnerable › Vulnerabilities
CVE-2022-3852: VR Calendar <= 2.3.3 - Cross-Site Request Forgery
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-03 · updated 2026-06-17
- Weakness: CWE-352
Description
The VR Calendar plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.3.3. This is due to missing or incorrect nonce validation on several functions. This makes it possible for unauthenticated attackers to delete, and modify calendars as well as the plugin settings, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- innate-images-llc VR Calendar: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: innate-images-llc VR Calendar 2.3.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/vr-calendar-sync/tags/2.3.2/Admin/Classes/VRCalendarAdmin.class.php#L133
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2809350%40vr-calendar-sync&new=2809350%40vr-calendar-sync&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a868226f-4ca1-4ec1-b55e-3029e3ed2d5b?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3852
- https://plugins.trac.wordpress.org/browser/vr-calendar-sync/tags/2.3.2/Admin/Classes/VRCalendarAdmin.class.php#L133
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2809350%40vr-calendar-sync&new=2809350%40vr-calendar-sync&sfp_email=&sfph_mail=
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3852
Get alerted when CVE-2022-3852 or the next vulnerability affects your stack