What’s Vulnerable › Vulnerabilities
CVE-2022-38540
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-13 · updated 2026-06-17
- Weakness: CWE-89
Description
Archery v1.4.0 to v1.8.5 was discovered to contain a SQL injection vulnerability via the ThreadIDs parameter in the create_kill_session interface.
Affected products
- hhyo Archery: from 1.4.0 before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: hhyo Archery 1.9.0. Check the vendor advisory for mitigations.
References
- https://announcements.bybit.com/en-US/article/bybit-improves-the-security-of-the-open-source-community-blt626818c0ee8c48a6/
- https://github.com/hhyo/Archery/blob/v1.8.5/sql/urls.py#L148
- https://github.com/hhyo/Archery/issues/1841
- https://announcements.bybit.com/en-US/article/bybit-improves-the-security-of-the-open-source-community-blt626818c0ee8c48a6/
- https://github.com/hhyo/Archery/blob/v1.8.5/sql/urls.py#L148
- https://github.com/hhyo/Archery/issues/1841
Get alerted when CVE-2022-38540 or the next vulnerability affects your stack