What’s Vulnerable › Vulnerabilities
CVE-2022-3858: Chaty < 3.0.3 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-05 · updated 2026-06-17
Description
The Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line, WeChat, Email, SMS, Call Button WordPress plugin before 3.0.3 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as admin.
Affected products
- Premio Chaty: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: Premio Chaty 3.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d251b6c1-602b-4d72-9d6a-bf5d5ec541ec
- https://wpscan.com/vulnerability/d251b6c1-602b-4d72-9d6a-bf5d5ec541ec
Get alerted when CVE-2022-3858 or the next vulnerability affects your stack