What’s Vulnerable › Vulnerabilities
CVE-2022-38649: Apache Airflow Pinot provider allowed Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Pinot Provider, Apache Airflow allows an attacker to control commands executed in the task execution context, without write access to DAG files. This issue affects Apache Airflow Pinot Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Apache Airflow Pinot Provider is installed (Apache Airflow Pinot Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Pinot Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version.
Affected products
- Apache Airflow: before 2.3.0 — fixed in 2.3.0
- Apache-Airflow-Providers-Apache-Pinot: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.3.0; Apache-Airflow-Providers-Apache-Pinot 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/27641
- https://lists.apache.org/thread/033o1gbc4ly6dpd2xf1o201v56fbl4dz
- https://github.com/apache/airflow/pull/27641
- https://lists.apache.org/thread/033o1gbc4ly6dpd2xf1o201v56fbl4dz
Get alerted when CVE-2022-38649 or the next vulnerability affects your stack