What’s Vulnerable › Vulnerabilities

CVE-2022-38725

Description

An integer overflow in the RFC3164 parser in One Identity syslog-ng 3.0 through 3.37 allows remote attackers to cause a Denial of Service via crafted syslog input that is mishandled by the tcp or network function. syslog-ng Premium Edition 7.0.30 and syslog-ng Store Box 6.10.0 are also affected.

Affected products

How to fix

Upgrade to a fixed version: OneIdentity Syslog-Ng 3.38.1, 7.0.32; OneIdentity Syslog-Ng Store Box 6.0.5, 7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-38725 or the next vulnerability affects your stack