What’s Vulnerable › Vulnerabilities
CVE-2022-38778
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-08 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw (CVE-2022-38900) was discovered in one of Kibana’s third party dependencies, that could allow an authenticated user to perform a request that crashes the Kibana server process.
Affected products
- Decode-Uri-Component Project Decode-Uri-Component: before 0.2.1 — fixed in 0.2.1
- Kibana: from 7.0.0 before 7.17.9; from 8.0.0 before 8.6.1 — fixed in 7.17.9, 8.6.1
How to fix
Upgrade to a fixed version: Decode-Uri-Component Project Decode-Uri-Component 0.2.1; Kibana 7.17.9, 8.6.1. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-7-17-9-8-5-0-and-8-6-1-security-update/324661
- https://www.elastic.co/community/security
- https://discuss.elastic.co/t/elastic-7-17-9-8-5-0-and-8-6-1-security-update/324661
- https://www.elastic.co/community/security
Get alerted when CVE-2022-38778 or the next vulnerability affects your stack