What’s Vulnerable › Vulnerabilities
CVE-2022-38790
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Weave GitOps Enterprise before 0.9.0-rc.5 has a cross-site scripting (XSS) bug allowing a malicious user to inject a javascript: link in the UI. When clicked by a victim user, the script will execute with the victim's permission. The exposure appears in Weave GitOps Enterprise UI via a GitopsCluster dashboard link. An annotation can be added to a GitopsCluster custom resource.
Affected products
- Weave.Works Gitops: before 0.9.0; 0.9.0-rc1, 0.9.0-rc2, 0.9.0-rc3 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: Weave.Works Gitops 0.9.0. Check the vendor advisory for mitigations.
References
- https://docs.gitops.weave.works/docs/cluster-management/getting-started/#profiles-and-clusters
- https://docs.gitops.weave.works/docs/intro
- https://docs.gitops.weave.works/security/cve/enterprise/CVE-2022-38790/index.html
- https://www.weave.works/product/gitops-enterprise/
- https://docs.gitops.weave.works/docs/cluster-management/getting-started/#profiles-and-clusters
- https://docs.gitops.weave.works/docs/intro
- https://docs.gitops.weave.works/security/cve/enterprise/CVE-2022-38790/index.html
- https://www.weave.works/product/gitops-enterprise/
Get alerted when CVE-2022-38790 or the next vulnerability affects your stack