What’s Vulnerable › Vulnerabilities
CVE-2022-3880: AntiHacker < 4.20 - Subscriber+ Arbitrary Plugin Installation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Disable Json API, Login Lockdown, XMLRPC, Pingback, Stop User Enumeration Anti Hacker Scan WordPress plugin before 4.20 does not have proper authorisation and CSRF in an AJAX action, allowing any authenticated users, such as subscriber to call it and install and activate arbitrary plugins from wordpress.org
Affected products
- Disable Json API, Login Lockdown, XMLRPC, Pingback, Stop User Enumeration Anti Hacker Scan: before 4.20 — fixed in 4.20
How to fix
Upgrade to a fixed version: Disable Json API, Login Lockdown, XMLRPC, Pingback, Stop User Enumeration Anti Hacker Scan 4.20. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/24743c72-310f-41e9-aac9-e05b2bb1a14e
- https://wpscan.com/vulnerability/24743c72-310f-41e9-aac9-e05b2bb1a14e
Get alerted when CVE-2022-3880 or the next vulnerability affects your stack