What’s Vulnerable › Vulnerabilities
CVE-2022-3882: WP Memory < 2.46 - Subscriber+ Arbitrary Plugin Installation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Memory Usage, Memory Limit, PHP and Server Memory Health Check and Fix Plugin WordPress plugin before 2.46 does not have proper authorisation and CSRF in an AJAX action, allowing any authenticated users, such as subscriber to call it and install and activate arbitrary plugins from wordpress.org
Affected products
- Memory Usage, Memory Limit, PHP and Server Memory Health Check and Fix Plugin: before 2.46 — fixed in 2.46
How to fix
Upgrade to a fixed version: Memory Usage, Memory Limit, PHP and Server Memory Health Check and Fix Plugin 2.46. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a39c643f-eaa4-4c71-b75d-2c4fe34ac875
- https://wpscan.com/vulnerability/a39c643f-eaa4-4c71-b75d-2c4fe34ac875
Get alerted when CVE-2022-3882 or the next vulnerability affects your stack