What’s Vulnerable › Vulnerabilities
CVE-2022-3891: WP FullCalendar < 1.5 - Unauthenticated Arbitrary Post Access
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The WP FullCalendar WordPress plugin before 1.5 does not ensure that the post retrieved via an AJAX action is public and can be accessed by the user making the request, allowing unauthenticated attackers to get the content of arbitrary posts, including draft/private as well as password-protected ones.
Affected products
- WP FullCalendar: before 1.5 — fixed in 1.5
How to fix
Upgrade to a fixed version: WP FullCalendar 1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5a69965d-d243-4d51-b7a4-d6f4b199abf1
- https://wpscan.com/vulnerability/5a69965d-d243-4d51-b7a4-d6f4b199abf1
Get alerted when CVE-2022-3891 or the next vulnerability affects your stack