What’s Vulnerable › Vulnerabilities
CVE-2022-3892: WP OAuth Server < 4.2.2 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-05 · updated 2026-06-17
Description
The WP OAuth Server (OAuth Authentication) WordPress plugin before 4.2.2 does not sanitize and escape Client IDs, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- WP OAuth Server (OAuth Authentication): before 4.2.2 — fixed in 4.2.2
How to fix
Upgrade to a fixed version: WP OAuth Server (OAuth Authentication) 4.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/33dddaec-a32a-4fce-89d6-164565be13e1
- https://wpscan.com/vulnerability/33dddaec-a32a-4fce-89d6-164565be13e1
Get alerted when CVE-2022-3892 or the next vulnerability affects your stack