What’s Vulnerable › Vulnerabilities
CVE-2022-3900: Cooked Pro < 1.7.5.7 - Unauthenticated PHP Object Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-06-17
Description
The Cooked Pro WordPress plugin before 1.7.5.7 does not properly validate or sanitize the recipe_args parameter before unserializing it in the cooked_loadmore action, allowing an unauthenticated attacker to trigger a PHP Object injection vulnerability.
Affected products
- XjSv Cooked: before 1.7.5.7 — fixed in 1.7.5.7
How to fix
Upgrade to a fixed version: XjSv Cooked 1.7.5.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c969c4bc-82d7-46a0-88ba-e056c0b27de7
- https://wpscan.com/vulnerability/c969c4bc-82d7-46a0-88ba-e056c0b27de7
Get alerted when CVE-2022-3900 or the next vulnerability affects your stack