What’s Vulnerable › Vulnerabilities
CVE-2022-39047
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-120
Description
Freeciv before 2.6.7 and before 3.0.3 is prone to a buffer overflow vulnerability in the Modpack Installer utility's handling of the modpack URL.
Affected products
- freeciv: before 2.6.7; from 3.0.0 before 3.0.3 — fixed in 2.6.7, 3.0.3
How to fix
Upgrade to a fixed version: freeciv 2.6.7, 3.0.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/08/31/1
- https://bugs.debian.org/1017579
- https://osdn.net/projects/freeciv/ticket/45299
- https://www.openwall.com/lists/oss-security/2022/08/05/1
- http://www.openwall.com/lists/oss-security/2022/08/31/1
- https://bugs.debian.org/1017579
- https://osdn.net/projects/freeciv/ticket/45299
- https://www.openwall.com/lists/oss-security/2022/08/05/1
Get alerted when CVE-2022-39047 or the next vulnerability affects your stack