What’s Vulnerable › Vulnerabilities
CVE-2022-39051: Perl Code execution in Template Toolkit
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-05 · updated 2026-06-17
- Weakness: CWE-913
Description
Attacker might be able to execute malicious Perl code in the Template toolkit, by having the admin installing an unverified 3th party package
Affected products
- OTRS AG OTRS: from 6.0.0 through 6.0.32; from 7.0.0 before 7.0.37; from 8.0.0 before 8.0.25 — fixed in 7.0.37, 8.0.25
How to fix
Upgrade to a fixed version: OTRS AG OTRS 7.0.37, 8.0.25. Check the vendor advisory for mitigations.
References
- https://otrs.com/release-notes/otrs-security-advisory-2022-12/
- https://otrs.com/release-notes/otrs-security-advisory-2022-12/
Get alerted when CVE-2022-39051 or the next vulnerability affects your stack