What’s Vulnerable › Vulnerabilities
CVE-2022-39060: ChangingTec MegaServiSignAdapter - Improper Input Validation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-31 · updated 2026-06-17
- Weakness: CWE-20
Description
ChangingTech MegaServiSignAdapter component has a vulnerability of improper input validation. An unauthenticated remote attacker can exploit this vulnerability to access and modify HKEY_CURRENT_USER subkey (ex: AutoRUN) in Registry where malicious scripts can be executed to take control of the system or to terminate the service.
Affected products
- ChangingTec MegaServiSignAdapter: before 1.0.22.1004 — fixed in 1.0.22.1004
How to fix
Upgrade to a fixed version: ChangingTec MegaServiSignAdapter 1.0.22.1004. Check the vendor advisory for mitigations.
References
- https://www.twcert.org.tw/tw/cp-132-6887-6ed4f-1.html
- https://www.twcert.org.tw/tw/cp-132-6887-6ed4f-1.html
Get alerted when CVE-2022-39060 or the next vulnerability affects your stack