What’s Vulnerable › Vulnerabilities
CVE-2022-3907: Clerk < 4.0.0 - Authentication Bypass and API Keys Disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-203
Description
The Clerk WordPress plugin before 4.0.0 is affected by time-based attacks in the validation function for all API requests due to the usage of comparison operators to verify API keys against the ones stored in the site options.
Affected products
- Clerk: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Clerk 4.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7920c1c1-709d-4b1f-ac08-f0a02ddb329c
- https://wpscan.com/vulnerability/7920c1c1-709d-4b1f-ac08-f0a02ddb329c
Get alerted when CVE-2022-3907 or the next vulnerability affects your stack