What’s Vulnerable › Vulnerabilities
CVE-2022-3913: Rapid7 Nexpose Certificate Validation Issue
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-01 · updated 2026-06-17
- Weakness: CWE-295
Description
Rapid7 Nexpose and InsightVM versions 6.6.82 through 6.6.177 fail to validate the certificate of the update server when downloading updates. This failure could allow an attacker in a privileged position on the network to provide their own HTTPS endpoint, or intercept communications to the legitimate endpoint. The attacker would need some pre-existing access to at least one node on the network path between the Rapid7-controlled update server and the Nexpose/InsightVM application, and the ability to either spoof the update server's FQDN or redirect legitimate traffic to the attacker's server in order to exploit this vulnerability. Note that even in this scenario, an attacker could not normally replace an update package with a malicious package, since the update process validates a separate, code-signing certificate, distinct from the HTTPS certificate used for communication. This issue was resolved on February 1, 2023 in update 6.6.178 of Nexpose and InsightVM.
Affected products
- Rapid7 Nexpose: from 6.6.82 before 6.6.178 — fixed in 6.6.178
How to fix
Upgrade to a fixed version: Rapid7 Nexpose 6.6.178. Check the vendor advisory for mitigations.
References
- https://docs.rapid7.com/release-notes/nexpose/20230201/
- https://www.rapid7.com/blog/post/2022/12/07/cve-2022-4261-rapid7-nexpose-update-validation-issue-fixed/
- https://docs.rapid7.com/release-notes/nexpose/20230201/
- https://www.rapid7.com/blog/post/2022/12/07/cve-2022-4261-rapid7-nexpose-update-validation-issue-fixed/
Get alerted when CVE-2022-3913 or the next vulnerability affects your stack