What’s Vulnerable › Vulnerabilities
CVE-2022-39173
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-787
Description
In wolfSSL before 5.5.1, malicious clients can cause a buffer overflow during a TLS 1.3 handshake. This occurs when an attacker supposedly resumes a previous TLS session. During the resumption Client Hello a Hello Retry Request must be triggered. Both Client Hellos are required to contain a list of duplicate cipher suites to trigger the buffer overflow. In total, two Client Hellos have to be sent: one in the resumed session, and a second one as a response to a Hello Retry Request message.
Affected products
- wolfSSL: before 5.5.1 — fixed in 5.5.1
How to fix
Upgrade to a fixed version: wolfSSL 5.5.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/169600/wolfSSL-Buffer-Overflow.html
- http://seclists.org/fulldisclosure/2022/Oct/24
- https://blog.trailofbits.com/2023/01/12/wolfssl-vulnerabilities-tlspuffin-fuzzing-ssh/
- https://github.com/wolfSSL/wolfssl/releases
- https://www.wolfssl.com/docs/security-vulnerabilities/
- http://packetstormsecurity.com/files/169600/wolfSSL-Buffer-Overflow.html
- http://seclists.org/fulldisclosure/2022/Oct/24
- https://blog.trailofbits.com/2023/01/12/wolfssl-vulnerabilities-tlspuffin-fuzzing-ssh/
- https://github.com/wolfSSL/wolfssl/releases
- https://www.wolfssl.com/docs/security-vulnerabilities/
Get alerted when CVE-2022-39173 or the next vulnerability affects your stack