What’s Vulnerable › Vulnerabilities
CVE-2022-39176
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-02 · updated 2026-06-17
Description
BlueZ before 5.59 allows physically proximate attackers to obtain sensitive information because profiles/audio/avrcp.c does not validate params_len.
Affected products
- BlueZ: before 5.59 — fixed in 5.59
- Canonical Ubuntu Linux: 18.04, 20.04
- Debian Linux: 10.0
How to fix
Upgrade to a fixed version: BlueZ 5.59. Check the vendor advisory for mitigations.
References
- https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1977968
- https://lists.debian.org/debian-lts-announce/2022/10/msg00026.html
- https://security.netapp.com/advisory/ntap-20221020-0002/
- https://ubuntu.com/security/notices/USN-5481-1
- https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1977968
- https://lists.debian.org/debian-lts-announce/2022/10/msg00026.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00022.html
- https://security.netapp.com/advisory/ntap-20221020-0002/
- https://ubuntu.com/security/notices/USN-5481-1
Get alerted when CVE-2022-39176 or the next vulnerability affects your stack