What’s Vulnerable › Vulnerabilities
CVE-2022-39213: Out-of-bounds Read in go-cvss
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-15 · updated 2026-06-17
- Weakness: CWE-125
Description
go-cvss is a Go module to manipulate Common Vulnerability Scoring System (CVSS). In affected versions when a full CVSS v2.0 vector string is parsed using `ParseVector`, an Out-of-Bounds Read is possible due to a lack of tests. The Go module will then panic. The problem is patched in tag `v0.4.0`, by the commit `d9d478ff0c13b8b09ace030db9262f3c2fe031f4`. Users are advised to upgrade. Users unable to upgrade may avoid this issue by parsing only CVSS v2.0 vector strings that do not have all attributes defined (e.g. `AV:N/AC:L/Au:N/C:P/I:P/A:C/E:U/RL:OF/RC:C/CDP:MH/TD:H/CR:M/IR:M/AR:M`). As stated in [SECURITY.md](https://github.com/pandatix/go-cvss/blob/master/SECURITY.md), the CPE v2.3 to refer to this Go module is `cpe:2.3:a:pandatix:go_cvss:*:*:*:*:*:*:*:*`. The entry has already been requested to the NVD CPE dictionary.
Affected products
- pandatix go-cvss: from 0.2.0 before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: pandatix go-cvss 0.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/pandatix/go-cvss/blob/master/SECURITY.md
- https://github.com/pandatix/go-cvss/commit/d9d478ff0c13b8b09ace030db9262f3c2fe031f4
- https://github.com/pandatix/go-cvss/security/advisories/GHSA-xhmf-mmv2-4hhx
- https://github.com/pandatix/go-cvss/blob/master/SECURITY.md
- https://github.com/pandatix/go-cvss/commit/d9d478ff0c13b8b09ace030db9262f3c2fe031f4
- https://github.com/pandatix/go-cvss/security/advisories/GHSA-xhmf-mmv2-4hhx
Get alerted when CVE-2022-39213 or the next vulnerability affects your stack