What’s Vulnerable › Vulnerabilities
CVE-2022-3922: Broken Link Checker < 1.11.20 - Admin+ Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Broken Link Checker WordPress plugin before 1.11.20 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- wpmudev Broken Link Checker: before 1.11.20 — fixed in 1.11.20
How to fix
Upgrade to a fixed version: wpmudev Broken Link Checker 1.11.20. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/78054bd7-cdc2-4b14-9b5c-30f10e802d6b
- https://wpscan.com/vulnerability/78054bd7-cdc2-4b14-9b5c-30f10e802d6b
Get alerted when CVE-2022-3922 or the next vulnerability affects your stack