What’s Vulnerable › Vulnerabilities

CVE-2022-39225: Parse Server subject to Incorrect Resource Transfer Between Spheres

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.15, or 5.0.0 and above prior to 5.2.6, a user can write to the session object of another user if the session object ID is known. For example, an attacker can assign the session object to their own user by writing to the `user` field and then read any custom fields of that session object. Note that assigning a session to another user does not usually change the privileges of either of the two users, and a user cannot assign their own session to another user. This issue is patched in version 4.10.15 and above, and 5.2.6 and above. To mitigate this issue in unpatched versions add a `beforeSave` trigger to the `_Session` class and prevent writing if the requesting user is different from the user in the session object.

Affected products

How to fix

Upgrade to a fixed version: parse-community parse-server 4.10.15, 5.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-39225 or the next vulnerability affects your stack