What’s Vulnerable › Vulnerabilities
CVE-2022-39230: Security issue in fhir-works-on-aws-authz-smart
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-200
Description
fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.
Affected products
- awslabs fhir-works-on-aws-authz-smart: from 3.1.0 before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: awslabs fhir-works-on-aws-authz-smart 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/awslabs/fhir-works-on-aws-authz-smart/security/advisories/GHSA-vv7x-7w4m-q72f
- https://github.com/awslabs/fhir-works-on-aws-authz-smart/security/advisories/GHSA-vv7x-7w4m-q72f
Get alerted when CVE-2022-39230 or the next vulnerability affects your stack