What’s Vulnerable › Vulnerabilities
CVE-2022-39231: Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-287
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.
Affected products
- parse-community parse-server: before 4.10.16; from 5.0.0 before 5.2.7 — fixed in 4.10.16, 5.2.7
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.16, 5.2.7. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-r657-33vp-gp22
- https://github.com/parse-community/parse-server/security/advisories/GHSA-r657-33vp-gp22
Get alerted when CVE-2022-39231 or the next vulnerability affects your stack