What’s Vulnerable › Vulnerabilities
CVE-2022-39241: Possible Server-Side Request Forgery (SSRF) in webhooks
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-02 · updated 2026-06-17
- Weakness: CWE-918
Description
Discourse is a platform for community discussion. A malicious admin could use this vulnerability to perform port enumeration on the local host or other hosts on the internal network, as well as against hosts on the Internet. Latest `stable`, `beta`, and `test-passed` versions are now patched. As a workaround, self-hosters can use `DISCOURSE_BLOCKED_IP_BLOCKS` env var (which overrides `blocked_ip_blocks` setting) to stop webhooks from accessing private IPs.
Affected products
- discourse: before 2.8.10; 2.9.0-beta1, 2.9.0-beta10, 2.9.0-beta2, 2.9.0-beta3, 2.9.0-beta4, 2.9.0-beta5 (+4) — fixed in 2.8.10
How to fix
Upgrade to a fixed version: discourse 2.8.10. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-rcc5-28r3-23rr
- https://github.com/discourse/discourse/security/advisories/GHSA-rcc5-28r3-23rr
Get alerted when CVE-2022-39241 or the next vulnerability affects your stack