What’s Vulnerable › Vulnerabilities
CVE-2022-39245: Mist vulnerable to user providing a Sudo binary for authentication checks
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-287
Description
Mist is the command-line interface for the makedeb Package Repository. Prior to version 0.9.5, a user-provided `sudo` binary via the `PATH` variable can allow a local user to run arbitrary commands on the user's system with root permissions. Versions 0.9.5 and later contain a patch. No known workarounds exist.
Affected products
- makedeb mist: before 0.9.5 — fixed in 0.9.5
How to fix
Upgrade to a fixed version: makedeb mist 0.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/makedeb/mist/commit/e257561a32cffe3c541b265097959adaea3d6b67
- https://github.com/makedeb/mist/releases/tag/v0.9.5
- https://github.com/makedeb/mist/security/advisories/GHSA-pxg4-7c7r-2ww6
- https://github.com/makedeb/mist/commit/e257561a32cffe3c541b265097959adaea3d6b67
- https://github.com/makedeb/mist/releases/tag/v0.9.5
- https://github.com/makedeb/mist/security/advisories/GHSA-pxg4-7c7r-2ww6
Get alerted when CVE-2022-39245 or the next vulnerability affects your stack