What’s Vulnerable › Vulnerabilities
CVE-2022-39260: Git vulnerable to Remote Code Execution via Heap overflow in `git shell`
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-19 · updated 2026-06-17
- Weakness: CWE-122
Description
Git is an open source, scalable, distributed revision control system. `git shell` is a restricted login shell that can be used to implement Git's push/pull functionality via SSH. In versions prior to 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4, the function that splits the command arguments into an array improperly uses an `int` to represent the number of entries in the array, allowing a malicious actor to intentionally overflow the return value, leading to arbitrary heap writes. Because the resulting array is then passed to `execv()`, it is possible to leverage this attack to gain remote code execution on a victim machine. Note that a victim must first allow access to `git shell` as a login shell in order to be vulnerable to this attack. This problem is patched in versions 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4 and users are advised to upgrade to the latest version. Disabling `git shell` access via remote logins is a viable short-term workaround.
Affected products
- Apple Xcode: before 14.1 — fixed in 14.1
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36, 37
- git: before 2.30.6; from 2.31.0 before 2.31.5; from 2.32.0 before 2.32.4; from 2.33.0 before 2.33.5; from 2.34.0 before 2.34.5; from 2.35.0 before 2.35.5 — fixed in 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5
How to fix
Upgrade to a fixed version: Apple Xcode 14.1; git 2.30.6, 2.31.5, 2.32.4, 2.33.5. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Nov/1
- https://github.com/git/git/security/advisories/GHSA-rjr6-wcq6-83p6
- https://lists.debian.org/debian-lts-announce/2022/12/msg00025.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C7B6JPKX5CGGLAHXJVQMIZNNEEB72FHD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OHNO2FB55CPX47BAXMBWUBGWHO6N6ZZH/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UKFHE4KVD7EKS5J3KTDFVBEKU3CLXGVV/
- https://security.gentoo.org/glsa/202312-15
- https://support.apple.com/kb/HT213496
- http://seclists.org/fulldisclosure/2022/Nov/1
- https://github.com/git/git/security/advisories/GHSA-rjr6-wcq6-83p6
- https://lists.debian.org/debian-lts-announce/2022/12/msg00025.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C7B6JPKX5CGGLAHXJVQMIZNNEEB72FHD/
Get alerted when CVE-2022-39260 or the next vulnerability affects your stack