What’s Vulnerable › Vulnerabilities

CVE-2022-39261: Twig may load a template outside a configured directory when using the filesystem loader

Description

Twig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.

Affected products

How to fix

Upgrade to a fixed version: Drupal 9.3.22, 9.4.7; twigphp Twig 1.44.7, 2.15.3, 3.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-39261 or the next vulnerability affects your stack