What’s Vulnerable › Vulnerabilities
CVE-2022-39263: NextAuth.js Upstash Adapter missing token verification
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-28 · updated 2026-06-17
- Weakness: CWE-287
Description
`@next-auth/upstash-redis-adapter` is the Upstash Redis adapter for NextAuth.js, which provides authentication for Next.js. Applications that use `next-auth` Email Provider and `@next-auth/upstash-redis-adapter` before v3.0.2 are affected by this vulnerability. The Upstash Redis adapter implementation did not check for both the identifier (email) and the token, but only checking for the identifier when verifying the token in the email callback flow. An attacker who knows about the victim's email could easily sign in as the victim, given the attacker also knows about the verification token's expired duration. The vulnerability is patched in v3.0.2. A workaround is available. Using Advanced Initialization, developers can check the requests and compare the query's token and identifier before proceeding.
Affected products
- nextauthjs next-auth: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: nextauthjs next-auth 3.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextauthjs/next-auth/commit/d16e04848ee703cf797724194d4ad2907fe125a9
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-4rxr-27mm-mxq9
- https://github.com/nextauthjs/next-auth/commit/d16e04848ee703cf797724194d4ad2907fe125a9
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-4rxr-27mm-mxq9
Get alerted when CVE-2022-39263 or the next vulnerability affects your stack