What’s Vulnerable › Vulnerabilities
CVE-2022-39265: Mail settings' command parameter injection in mybb
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-74
Description
MyBB is a free and open source forum software. The _Mail Settings_ → Additional Parameters for PHP's mail() function mail_parameters setting value, in connection with the configured mail program's options and behavior, may allow access to sensitive information and Remote Code Execution (RCE). The vulnerable module requires Admin CP access with the `_Can manage settings?_` permission and may depend on configured file permissions. MyBB 1.8.31 resolves this issue with the commit `0cd318136a`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- mybb: before 1.8.31 — fixed in 1.8.31
How to fix
Upgrade to a fixed version: mybb 1.8.31. Check the vendor advisory for mitigations.
References
- https://github.com/mybb/mybb/blob/mybb_1830/install/resources/settings.xml#L2331-L2338
- https://github.com/mybb/mybb/commit/0cd318136a10b029bb5c8a8f6dddf39d87519797
- https://github.com/mybb/mybb/security/advisories/GHSA-hxhm-rq9f-7xj7
- https://mybb.com/versions/1.8.31/
- https://github.com/mybb/mybb/blob/mybb_1830/install/resources/settings.xml#L2331-L2338
- https://github.com/mybb/mybb/commit/0cd318136a10b029bb5c8a8f6dddf39d87519797
- https://github.com/mybb/mybb/security/advisories/GHSA-hxhm-rq9f-7xj7
- https://mybb.com/versions/1.8.31/
Get alerted when CVE-2022-39265 or the next vulnerability affects your stack