What’s Vulnerable › Vulnerabilities
CVE-2022-39269: Media transport downgrade from the secure version (SRTP) to non-secure (RTP) in pjsip
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-319
Description
PJSIP is a free and open source multimedia communication library written in C. When processing certain packets, PJSIP may incorrectly switch from using SRTP media transport to using basic RTP upon SRTP restart, causing the media to be sent insecurely. The vulnerability impacts all PJSIP users that use SRTP. The patch is available as commit d2acb9a in the master branch of the project and will be included in version 2.13. Users are advised to manually patch or to upgrade. There are no known workarounds for this vulnerability.
Affected products
- teluu pjsip: from 2.11 before 2.13 — fixed in 2.13
How to fix
Upgrade to a fixed version: teluu pjsip 2.13. Check the vendor advisory for mitigations.
References
- https://github.com/pjsip/pjproject/commit/d2acb9af4e27b5ba75d658690406cec9c274c5cc
- https://github.com/pjsip/pjproject/security/advisories/GHSA-wx5m-cj97-4wwg
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://security.gentoo.org/glsa/202210-37
- https://www.debian.org/security/2023/dsa-5358
- https://github.com/pjsip/pjproject/commit/d2acb9af4e27b5ba75d658690406cec9c274c5cc
- https://github.com/pjsip/pjproject/security/advisories/GHSA-wx5m-cj97-4wwg
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://security.gentoo.org/glsa/202210-37
- https://www.debian.org/security/2023/dsa-5358
Get alerted when CVE-2022-39269 or the next vulnerability affects your stack