What’s Vulnerable › Vulnerabilities
CVE-2022-39277: Cross-Site Scripting (XSS) in external links in GLPI
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-03 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI stands for Gestionnaire Libre de Parc Informatique. GLPI is a Free Asset and IT Management Software package that provides ITIL Service Desk features, licenses tracking and software auditing. External links are not properly sanitized and can therefore be used for a Cross-Site Scripting (XSS) attack. This issue has been patched, please upgrade to GLPI 10.0.4. There are currently no known workarounds.
Affected products
- glpi-project glpi: from 0.60 before 10.0.4 — fixed in 10.0.4
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rhcw-8r7g-8pwc
- https://huntr.dev/bounties/8e047ae1-7a7c-48e0-bee3-d1c36e52ff42/
- https://github.com/glpi-project/glpi/security/advisories/GHSA-rhcw-8r7g-8pwc
- https://huntr.dev/bounties/8e047ae1-7a7c-48e0-bee3-d1c36e52ff42/
Get alerted when CVE-2022-39277 or the next vulnerability affects your stack