What’s Vulnerable › Vulnerabilities
CVE-2022-39279: Discourse-chat plugin susceptible to XSS in channel name and description
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-79
Description
discourse-chat is a plugin for the Discourse message board which adds chat functionality. In versions prior to 0.9 some places render a chat channel's name and description in an unsafe way, allowing staff members to cause an cross site scripting (XSS) attack by inserting unsafe HTML into them. Version 0.9 has addressed this issue. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- discourse-chat: before 0.9 — fixed in 0.9
How to fix
Upgrade to a fixed version: discourse-chat 0.9. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse-chat/commit/25737733af48e5b9fa60b0561d7fde14bea13cce
- https://github.com/discourse/discourse-chat/security/advisories/GHSA-qp62-8m3c-9jgj
- https://github.com/discourse/discourse-chat/commit/25737733af48e5b9fa60b0561d7fde14bea13cce
- https://github.com/discourse/discourse-chat/security/advisories/GHSA-qp62-8m3c-9jgj
Get alerted when CVE-2022-39279 or the next vulnerability affects your stack