What’s Vulnerable › Vulnerabilities
CVE-2022-39280: Regular expression denial of service in dparse
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-400
Description
dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.
Affected products
- Pyup Dependency Parser: before 0.5.1 — fixed in 0.5.1
How to fix
Upgrade to a fixed version: Pyup Dependency Parser 0.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/pyupio/dparse/commit/8c990170bbd6c0cf212f1151e9025486556062d5
- https://github.com/pyupio/dparse/commit/d87364f9db9ab916451b1b036cfeb039e726e614
- https://github.com/pyupio/dparse/security/advisories/GHSA-8fg9-p83m-x5pq
- https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS
- https://github.com/pyupio/dparse/commit/8c990170bbd6c0cf212f1151e9025486556062d5
- https://github.com/pyupio/dparse/commit/d87364f9db9ab916451b1b036cfeb039e726e614
- https://github.com/pyupio/dparse/security/advisories/GHSA-8fg9-p83m-x5pq
- https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS
Get alerted when CVE-2022-39280 or the next vulnerability affects your stack