What’s Vulnerable › Vulnerabilities
CVE-2022-39288: Denial of service in Fastify via Content-Type header
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 59.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-754
Description
fastify is a fast and low overhead web framework, for Node.js. Affected versions of fastify are subject to a denial of service via malicious use of the Content-Type header. An attacker can send an invalid Content-Type header that can cause the application to crash. This issue has been addressed in commit `fbb07e8d` and will be included in release version 4.8.1. Users are advised to upgrade. Users unable to upgrade may manually filter out http content with malicious Content-Type headers.
Affected products
- fastify: before 4.8.1 — fixed in 4.8.1
How to fix
Upgrade to a fixed version: fastify 4.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/fastify/fastify/commit/fbb07e8dfad74c69cd4cd2211aedab87194618e3
- https://github.com/fastify/fastify/security/advisories/GHSA-455w-c45v-86rg
- https://github.com/fastify/fastify/security/policy
- https://github.com/fastify/fastify/commit/fbb07e8dfad74c69cd4cd2211aedab87194618e3
- https://github.com/fastify/fastify/security/advisories/GHSA-455w-c45v-86rg
- https://github.com/fastify/fastify/security/policy
Get alerted when CVE-2022-39288 or the next vulnerability affects your stack